Skip to main content.

vyatta 設定

 
わりと手間取ったのでvyattaに関する設定のメモ。

「vyattaってなに?ブイヤッタって読むの?」
とか思った人は回れ右して

やる夫のジグソウゲーム
http://mukankei961.blog105.fc2.com/blog-entry-4371.html


でも見ていることをオススメするんよ!




それにしても、
日本vyattaユーザ会のロゴって何かに似てる気がするのですが

null


まぁ、気のせいだよね!



そういうわけで以下、vyatta設定メモ。
インストールと基本操作ははGIGAZINE参考。
パソコンを業務用途にも耐えうる高性能ブロードバンドルータにしてしまう「Vyatta」
http://gigazine.net/news/20080426_vyatta/



まずインストールしたらやっておくべきこと。
それはパスワードの変更です。

デフォルトではvyattaユーザのパスワードは「vyatta」なので、セキュリティ上すぐに変更しておいた方が良いです。

#パスワードの変更
set system login user vyatta authentication ↓
plaintext-password (パスワード)



次にインターフェースのIPを設定。
今回は

eth0は外向けでIPは、192.168.1.1
eth1は内向けでIPは、192.168.0.1

とします。

#eth0設定
set interfaces ethernet eth0 address 192.168.1.1/24

#eth1設定
set interfaces ethernet eth1 address 192.168.0.1/24



pppoeの設定。
プロバイダの接続情報(IDとパスワード)を入力します。

#pppoe作成
set interfaces ethernet eth0 pppoe 0

#プロバイダ情報
set interfaces ethernet eth0 pppoe 0 ↓
user-id (プロバイダの接続ID)
set interfaces ethernet eth0 pppoe 0 ↓
password (プロバイダの接続パスワード)

set interfaces ethernet eth0 pppoe 0 default-route auto
set interfaces ethernet eth0 pppoe 0 name-server auto
set interfaces ethernet eth0 pppoe 0 local-address ↓
192.168.1.1



ゲートウェイ設定。
# ゲートウェイ設定
set protocols static route 0.0.0.0/0 next-hop 192.168.1.1
set system gateway-address 192.168.0.1



DNS設定。
通常ならプロバイダ指定のものか別途自分で立てたDNSのアドレスなどで良いと思いますが、今回「8.8.8.8」と「8.8.4.4」で設定。
これはGoogleのパブリックDNSサービスのアドレスです。
詳細は「8.8.8.8」でググってもらえばOKかと。

# DNS設定
set system name-server 8.8.8.8
set system name-server 8.8.4.4



DHCP設定。

自動割り当ての設定。
これはサーバ用途にのみ利用するのなら必要無いとは思うのですが、何かの理由でWindowsPCから利用する場合などもあるかなぁと思ったので。
割り当て範囲は192.168.0.4〜192.168.0.50まで。

# DHCP設定
# ローカルIPの割り振り設定
set service dhcp-server shared-network-name home ↓
subnet 192.168.0.1/24 start 192.168.0.4
stop 192.168.0.50


そんで次はDHCPの静的割り当て。
「A」というPCで接続してきた場合は毎回「***.***.***.***」という固定のローカルIPを割り振りなさいという設定。

# 静的割り当て
set service dhcp-server shared-network-name ↓
home subnet 192.168.0.1/24
static-mapping rule1 ip-address (サーバのローカルIP)
set service dhcp-server shared-network-name ↓
home subnet 192.168.0.1/24
static-mapping rule1 mac-address (サーバのMACアドレス)




NAT設定。
IPマスカレードとかportの設定など。
ルールの番号が1,8,25と飛び飛びな件については特に理由無しです。

# NAT設定
# マスカレード
set service nat rule 1 outbound-interface pppoe0
set service nat rule 1 type masquerade
# http(80番ポート)
set service nat rule 8 inbound-interface pppoe0
set service nat rule 8 destination port http
set service nat rule 8 protocol tcp
set service nat rule 8 type destination
set service nat rule 8 inside-address address ↓
(サーバのローカルIP)
# 21番ポート(ftp)
set service nat rule 25 inbound-interface pppoe0
set service nat rule 25 destination port 21
set service nat rule 25 protocol tcp
set service nat rule 25 type destination
set service nat rule 25 inside-address address ↓
(サーバのローカルIP)



ホスト名とかドメイン名の設定

# その他設定
set system domain-name (ドメイン)
set system host-name (ホスト名)



反映
# 反映
commit



動作確認をして特に挙動におかしい点がなければ保存。
念のために上手く動作している現況の設定を別名保存して取っておく。

# 別名保存
save good.conf
保存されたデータは「/opt/vyatta/etc/config/」内に保存されるので、どこかにバックアップを取っておくのもよいかと。






以上、自分用の備忘録 兼 悩める子羊ちゃんへの一助となれば良いかと思う反面、
何か間違ってたらゴメンナサイ的な・・・そんな感じです。



それ以前に、

「eth1とかNatとかDHCPとか何言ってるの、この人?」
という疑問を持った人は、自分の尻の穴にLANケーブルを差し込んで

「あぁー、プロキシもアンチウィルスも無いのに生で(インターネットに)繋がってるりゅぅぅぅ!!!」


とか言って遊ぶがいいさ!
その方がきっと幸せになれます。

なんというか、
ルータをいじってる人の思考なんて皆こんなものなんだよ!

(勿論、嘘です)



このエントリーをはてなブックマークに追加
 

comments powered by Disqus