Skip to main content.
ログインしてなきゃ、キャッシュが効いてちゃんと見られるんですが、ログインしている状態だと真っ白。

あからさまなPHPエラーの症状。


「どういうこっちゃ?」と思って調べてみるとデバッグでこんなエラーが。


WordPress データベースエラー: [Got a packet bigger than 'max_allowed_packet' bytes]


ほうほう、MySQLの設定の問題ですかぁー↑と思って、サーバ管理会社に設定変更のお願いメール送ったんですよ。


そしたら、こんな返事が。

・サーバを調べましたところ、WordPress のバージョン 4.3 をご利用のようでした。
・WordPress のバージョン 4.3ですが,wp-cron にサーバリソースを圧迫する不具合があるようです。
・現在修正版のリリース日が未定です。
・WordPress のバージョンを一度 4.2.4 等へ戻していただけますでしょうか?



確かにエラー出したクエリを見てたら、"option_name = cron"ってクエリでした。

というわけで、バージョンを戻したらするっと直りました。

もう最近は新バージョン出たら、考え無しにWordpressのアップデートしてましたがたまにはこういうのもあるんですね。
そもそも、MySQLのmax_allowed_packetの値が低くなければこのエラーも出ないんじゃなかったのか、とも思ふわけですが。
«Prev || 1 · | Next»